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LAB 1
ANALOGUE MEASURING

INSTRUMENT

I. GOAL
In this lab, student will have skills:

= Using Analog VOM.
= Reading and measuring resistor values, testing electronic components such as

capacitor, inductor, transformer, diode and BJT.

II. SUMMARY OF THEORY
a. Analog VOM
Picture 1.1 describes fundamental components of an Analog VOM using

galvanometer.

Meter Mirror
Meter Pointer
Meter Scale
Zero Adjustment
screw
002 Adjustment Knob
{on the side)
RAMGE —
Switch
W + Terminal
12A _
Terminal —COM Terminal

Picture 1.1. Analog VOM using galvanometer.
On this equipment:
» -COM terminal is connected to Black probe.
» +Terminal is connected to Red probe.
»  0QADJ knob is used to calibrate 0 Ohm value. It is required in measuring
resistant value.
* RANGE Switch is used to select which electronic unit will be measured and its

scale. Normally, an Analog VOM has DC.V to measure DC voltage, AC.V to



measure AC voltage, DCmA/A to measure DC current and Q to measure

resistance.

= Zero Adjustment Screw to calibrate the Zero position of meter pointer (normally,

at the left side).

= Picture 1.2 shows ranges and unit on a display of an Analog VOM.

Voltage & current Ohms
ranges range
\ I
falt] 15
& N 40 60 0%
© &
(] ;:%
%

Picture 1.2. Range and Unit.

. Breadboard

Breadboard is a tool to help building electronic circuits with wires and
components. It has many strips of metal (copper usually) which run underneath
the board. Picture 1.3 shows the internal structure of a breadboard.

e
T

\.3:,5

Picture 1.3. Breadboard and inside



III. PRACTICE
a. Equipment

* Analog VOM.

= Breadboard, resistors, capacitors, inductors, transformer, diodes and BJT.

b. Measure OHM with Analog VOM
*Note: if you are planning to measure Ohm on a circuit, its power supply
must be turned off before using Ohmmeter.

= Step 1: Select a suitable OHM scale.

= Step 2: Touch two probes (Red and Black) of VOM to each other.

= Step 3: Adjust the 0QADJ knob to move needle to Zero OHM position.

Picture 1.4. Adjusting Zero point

= Step 4: Place the two probes at the two terminals of a resistor to measure as in

Picture 1.5.

; -r N

Picture 1.5. Measuring resistor with Analog VOM

wiki



c.

Step 5: Read the value on display and compare to value calculated from color

code of the resistor.

** HOW TO READ OHM VALUE ON DISPLAY
o Xl scale:
Value = Needle position (ex.: 20 QX 1 = 20 Q)
o XI0 scale:
Value = Needle position X 10 (ex.: 20 Q X 10 = 200 Q)
o X100 scale:
Value = Needle position X 100 (ex.: 20 Q X 100 = 2000 )
o Xlkscale:
Value = Needle position X 1 k Q (ex.: 20 Q X 1 k=20 kQ)
o X0k scale:
Value = Needle position X 10 k Q (ex.: 20 Q X 10 k = 20 kQ)

Picture 1.6. Reading value on Analog VOM display
Testing capacitor with Analog VOM
Step 1: Select a suitable OHM scale.
Step 2: Place the two probes onto two terminals of a capacitor.
Step 3: Tracking movement of needle:
o Ifneedle goes up then goes down, the capacitor is good.
o Ifneedle goes up without goes down, the capacitor is shorted.
o Ifneedle does not move, the capacitor is opened or the current OHM scale
is not suitable (large scale should be used for small capacitance and

otherwise).



d. Testing inductor and transformer with Analog VOM
= Step 1: Select X1 on OHM scale.
= Step 2: Measure resistance of an inductor.

= Step 3: Measure resistances of primary coil and secondary coil.

e. Testing diode with Analog VOM
= Step 1: Select X10 or X100 on OHM scale
= Step 2: Place Red probe on Cathode terminal, Black probe on Anode terminal of
a diode.
= Step 3: Tracing movement of needle:
o Ifneedle goes up, the diode may be good.
o Ifneedle does not move, the diode is broken.
= Step 4: Place Black probe on Cathode terminal, Red probe on Anode terminal of
a diode.
= Step 5: Tracing movement of needle:
o Ifneedle does not move, the diode is good.

o If needle goes up, the diode is shorted.

Forward Bias Reverse Bias

Cathode

Positive Cathod Positive

Polarity  Anode e | Polarty
+

Negative

Anode Cathode & | | / ) e v TJ
(+) By SRS s <=

Step 2: The diode is FORWARD BIASED Step 4: The diode is REVERSE BIASED

Picture 1.7. Testing diode with Analog VOM



f. Testing BJT with Analog VOM
= Step 1: Select X10 or X100 on OHM scale
= Step 2: Try the 6 combinations and when you have the black probe on a pin and
the red probe touches the other pins and the meter swings nearly full scale, you
have an NPN transistor. The black probe is BASE.
o Ifthe red probe touches a pin and the black probe produces a swing on the
other two pins, you have a PNP transistor. The red probe is BASE
o If the needle swings FULL SCALE or if it swings for more than 2
readings, the transistor is FAULTY.

. e

This is an NPN transistor This is a PNP transistor
The black probe is the BASE  Theredprobe is the BASE

Picture 1.8. Testing BJT with Analog VOM

g. Measure DC Voltage with Analog VOM

= Step 1: Select the maximum DCV scale.

= Step 2: Place Black probe on the lower voltage point (usually GND), Red probe
on higher voltage point.

= Step 3: Read value from display.

= Step 4: If the value is too small to read, select lower DCV scale.

h. Measure AC Voltage with Analog VOM
= Step 1: Select the maximum ACV scale.
= Step 2: Place Black probe on the lower voltage point (usually GND), Red probe

on higher voltage point.



IV.

= Step 3: Read value from display.

= Step 4: If the value is too small to read, select lower ACV scale.

PREPARATION AT HOME

Equations for converting between voltage source and current source?

REPORT

Filling the practice results into template of report in the next page.



LABOTORY REPORT

LAB 1: ANALOGUE MEASURING INSTRUMENT

Date:.....cccvvveeeveen ...

Time: ..o e e

Class: ..o, FS@SSTONE Lo, *Group: .......ooieinnn.
Members: - MAIMIE: .........oooiiiiiiitiiiie e, ,studentID: ....................
o 1 ;1 11 (- ,studentID: ....................
TABLE OF RESULTS
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LAB 2
DIGITAL MEASURING INSTRUMENT

I. GOAL
In this lab, student will have skills:

= Using Digital VOM, Oscilloscope and Function Generator.
» Reading and measuring resistor values, testing electronic components such as

capacitor, inductor, transformer, diode and BJT.

II. SUMMARY OF THEORY
a. Digital VOM (DMM)
Picture 2.1 describes fundamental components of a Digital VOM (DMM)

1. LCD Display — 1
2. Power Button 2 ) <l 5
3. Rotary Switch TR 1 )

4. Input Terminals '. \m’

5. HOLD Button | — '

Picture 2.1. Digital VOM.

= LCD displays measured values.

»  Power Button turns on or off the equipment.

* Rotary Switch selects which electronic unit will be measured and its scale.

» Input Terminals connects to probes, the COM hole connects to Black probe.

» HOLD Button pauses the equipment and keep the last value on LCD. To

measure continuously, release this button from pressed state.

Digital VOM is easier to use than Analog VOM, its display is clear and easy to

read out small values.

Operating controls: reference to Digital VOM Manual in Appendix A.
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b. OSCILLOSCOPE

UL

Picture 2.2. Oscilloscope

Operating Controls, Indicators and Signal input connectors: reference to

Oscilloscope Manual in Appendix B.

¢. Function Generator
Function Generator is a device generating waves for testing. Picture 2.3 shows a
picture of a Function Generator.

@ ©) @

| 1|

™ e

VNG DUTPLT

Picture 2.3. A Function Generator.

Operating Controls, Indicators and Signal input connectors: reference to

Function Generator Manual in Appendix C.

12



III. PRACTICE
d. Equipment
= Digital VOM.
= Breadboard, resistors, capacitors, inductors, transformer, diodes and BJT.
= Oscilloscope

=  Function Generator.

e. Measure OHM with Digital VOM

= Step 1: Turn on Digital VOM

= Step 2: Connect Black probe to COM hole, Red probe to QmA hole.
= Step 3: Select suitable Q scale.

= Step 4: Place the two probes onto two terminals of a resistor.

= Step 5: Read value on LCD, unit of value is the unit of the selected € scale.

Picture 2.4. Measure resistance with Digital VOM

f. Testing diode with Digital VOM

= Step 1: Turn on Digital VOM

= Step 2: Connect Black probe to COM hole, Red probe to QmA hole.

= Step 3: Select diode symbol >

= Step 4: Place Red probe on Anode terminal, Black probe on Cathode terminal of
a diode.

= Step 5: [f LCD value is different from “1”, the diode may be good.

13



= Step 6: Place Black probe on Anode terminal, Red probe on Cathode terminal of
a diode.

= Step 7: If LCD value is “1”, the diode is good.

Picture 2.5. Testing diode with Digital VOM

g. Measure DC Voltage with Digital VOM

= Step 1: Select the maximum VISR scale.

= Step 2: Place Black probe on the lower voltage point (usually GND), Red probe
on higher voltage point.

= Step 3: Read value from display.

= Step 4: If the value is too small to read, select lower scale.

h. Measure AC Voltage with Digital VOM

= Step I: Select the maximum V"™ scale.

= Step 2: Place Black probe on the lower voltage point (usually GND), Red probe
on higher voltage point.

= Step 3: Read value from display.

= Step 4: If the value is too small to read, select lower ACV scale.
i. Oscilloscope and Function Generator

Oscilloscope

= Step 1: Select scale on probe of Oscilloscope to X1

14



Picture 2.6. Select scale X1 on Oscilloscope probe

Step 2: Turn ON POWER (30), LED (32) will light when Oscilloscope is
powered on.

Step 3: Vary INTENSITY (31) to change brightness.

Step 4: Vary FOCUS (28) to select focus of beam on display.

Step 5: Select input channel using VERT MODE (7) to channel 1 (CHI).

Step 6: Select SOURCE (23) to CHI.

Step 7: Make sure that X-Y (19) button is not pressed.

Step 8: Rotate VAR (5) clockwise until hearing a “click” sound.

Step 9: Rotate VAR SWEEP (22) clockwise to the most right position.

Step 10: Connect probe to CAL (9) to test Oscilloscope and the probe.

Step 11: Select AC-GND-DC Switch (1) to GND.

Step 12: Vary POSITION (27) until seeing a line of beam in the middle of screen.
Step 13: Select AC-GND-DC Switch (1) to AC.

Step 14: Rotate TIME / DIV (15) to position .5 mS

Step 15: Vary VOL / DIV (4) until seeing a square wave on screen.

Picture 2.7. Square wave on Oscilloscope screen
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IV.

= Step 16: Using equations in TIME MEASUREMENTS, FREQUENCY
MEASUREMENTS and MEASUREMENT OF VOLTAGE BETWEEN TWO
POINT ON A WAVEFORM in Oscilloscope Manual (Appendix C) to calculate

period, frequency and peak-peak voltage of the captured wave.
Function Generator

= Step 17: Turn on POWER (1) on Function Generator, LED ON will light when
Function Generator is powered on.

= Step 18: Rotate RANGE (11) to 1K.

= Step 19: Rotate FUNCTION (10) to Sine wave.

= Step 20: Rotate FREQUENCY (2) to 1.5 position.

= Step 21: Rotate OFFSET (7) counter-clockwise to the most left position.

= Step 22: Connector cable to OUTPUT (5).

= Step 23: Connect the cable in step 22 to Oscilloscope probe.

= Step 24: Check waveform on Oscilloscope screen and calculate period |,

frequency and peak-peak voltage of this wave.

PREPARATION AT HOME

Equation to calculate voltage between two points on Oscilloscope?

REPORT

Filling the practice results into template of report in the next page.
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LAB3

ELECTRONIC CAD SOFTWARE

I1.

GOAL
In this lab, student will have skills:
» Understanding netlist of schematic.

= Using Electronic CAD software in schematic design and simulation.

SUMMARY OF THEORY
Electronic CAD software is computer program helping engineers in designing
schematic, PCB and running circuit simulation. To simulate a circuit, SPICE is the

most popular tool. The following picture and code shows an example of SPICE

program:
R1
KL * Any text after the asterisk '*'is ignored by SPICE
v * Voltage Divider
— 12V
R2 wviI1012
A RI 12 1000
rR2 2 02000

.OP * perform a DC operating point analysis
.END
Picture 3.1. Voltage Divider circuit and Netlist.

There are many Electronic CAD softwares over the world. In this lab, OrCAD PCB
Designer Lite is used in practice because of rich features and free. OrCAD Lite is
fully functional and offers every feature of OrCAD, limited only by the size and
complexity of the design. There is no time limit for OrCAD Lite, you can use it as
long as you want.

= OrCAD Capture: it is one of the most widely used schematic design solutions

for the creation and documentation of electrical circuits.

18



= OrCAD CIS: CIS (component information system) is product for component
data management, along with highly integrated flows supporting the
engineering process

= OrCAD PSpice® A/D and Advanced Analysis: OrCAD® PSpice® and
Advanced Analysis technology combine industry-leading, native analog,
mixed-signal, and analysis engines to deliver a complete circuit simulation
and verification solution.

= OrCAD PCB Editor: it is a tool to design a PCB (Printed Circuit Board) from

a schematic.

III. PRACTICE
a. Equipment

= OrCAD PCB Designer Lite

b. Schematic
Step 1: open Capture CIS Lite from Start Menu or Shortcut on Desktop.
Step 2: select File->New->Project

OrCAD Capture CIS - Lite - [Start Page]
Design Edit View Tools Place SlAnalysis Accessories Options Window Help

New Project... =)
f — f— JEd & : @
| Open L3 Design
Close Ctrl+F4 Library
| VHDLFile
| “heck and Save Verilog File
F Save As... TextFile
Import L
Export v Getting Started
Print Setup... oﬁ MNew Design '0% MNew Project
Print Area 4
1 C\Usersh...\test\test.opj Open Design t Open Praject
Exit
Recent Files
‘ File name Created Date
| sarninn Recniirras

Picture 3.2. File->New->Project
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Step 3: in New Project box, put a name for project in Name, select design type as

in the picture below. After that, select OK to continue.

New Project X
Name
|bai_21 Cancel
Create a Mew Project Using Help
=
% (®) PSpice Analog or Mixed 470 Tip for Mew Users
Create a hew Analog ar
= Mixed A/D project. The
% () PC Board ‘wizard new project may be blank
of copied fram an existing

template.

] g? () Programmable Logic YWizard
¢ ]

y : Learn With
ﬁ © Schematic Exarn ind
Location
| C:AUsershltkhatDocuments\Projectsitest Erowse. .

Picture 3.3. Set name and type for project

Step 4: OrCAD will ask you to create a blank project or using existing project,

select “Create a blank project” as in Picture 3.4.

Create PSpice Project ®
() Create based upon an existing project
AnalogGMDSymbol opj Browse...

Cancel

(®) Create a blank project

Help

Picture 3.4. Create a blank project

Step 5: a blank page will open as in Picture 3.5

OrCAD Capture CIS - Lite - [/ - (SCHEMATICT : PAGET)] =
Fl File Design Edit View Tools Place SlAnalysis PSpice Accessories Options Window Help cadence® - 5 x

ER=g= g ] L "aqA] > Eame@ [ M-
RARAA & 1 12 L |+ |8
@

o eea 0 e |

il A R Ny 5 o
LR W

22 B AP 0 4+
2 HLO®

Picture 3.5. Blank page for design
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Step 6: go to Place->PSpice Component...->Resistor to pick up a resistor. After

that, a resistor symbol will occur under your cursor.

r apture =y = -
QrCAD Cap CI5 - Lite - [/ - (SCHEMATICT : PAGET)]
E File Design Edit View Tools m Sl Analysis  PSpice  Accessories Options  Window Help

EEd& omir. ey R RRAQ @
o [ | @ > hwauows ]
PSpice Component... PSpice Ground
! terized Part Capacitor I
| Database Part Z Diode
[ Start Page " bai_2.0pj @ 1 Wire W Inductor
! Auto Wire 4 Resistor N T—
1. Bus B Digital 5
«= Junction J Discrete >
"I Bus Entry E Passives 4
= Met Alias... M i ¥
E “¥ Power... F =
+ Ground... G seh
[l Off-Page Connector.. Modeling Application... r
¥, Hierarchical Block...
B <> Hierarchical Port...

Picture 3.6. Place->PSpice Component...->Resistor

Step 7: left-click on white page to place the resistor above.

1 Pace1* ]

Picture 3.7: Placing a resistor

Step 8: select the resistor above, hold left button on your mouse and move your

mouse to move the component to anywhere on the design page.
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Step 9: select the resistor above, press R to rotate it 90 degree.

Picture 3.8. Select then press R to rotate 90 degree.

Step 10: Place another resistor under the resistor above (follow the step 6 to step

9)

O
=8

Picture 3.9. Place R2

Step 11: go to Place->PSpice Component...->Source->Voltage Sources->DC to

place a DC voltage source

+= [/ - (SCHEMATICT : PAGET]]
ew Tools Sl Analysis  PSpice Accessories Options  Window Help

_ S Feaq@ag em! Haweq [
& | Pl [ L L [ 1
PSpice Component... PSpice Ground
Capacitor @‘
Database Part 4 Diode
opr* Bl | A wire w Tidiciog
Auto Wire L4 Resistor 2 I H I
1 Bus 8 Digital L
<% Junction J Diceret= »
A BusEntry E Passives +
= Net Alias... N Source Controlled Sources L)
Z.F Power... F Searchin Current Sources 3 |
% Ground... G : : Voltage Sources AC |
[C}. Off-Page Connector... Muodeling Application... L -r_r-wi oe |
I, Hierarchical Block... Pulse |
< Hierarchical Port... Sine |
F % sz Exponential |
|-K Mo Connect X EM Sine |
]
Title Block...
Bookmark...
s Text... T
T line Shiftal

Picture 3.10. Place->PSpice Component...->Source->Voltage Sources->DC
22



Step 12: click on design page to place V1

Picture 3.11. Place a DC voltage source

Step 13: go to Place->Wire (or press W) to go to wiring mode. If you want to

quit from this mode, press Esc on your keyboard.

(SCHEMATICT : PAGET)]

Tnolsm 5l Analysis  PSpice  Accessories Options  Window Help

e T PR R @
| & Part... p l ;
PSpice Compeonent... L4

it

Databaze Part
1 Wire w

[ £ IS L L 1t

@

|[=] #

Auto Wire 4

1L Bus

= lunction

A BusEntry

= Net Alias...

£ Power...

% Ground...

[ Off-Page Connector...
., Hierarchical Block...
< Hierarchical Port...

G M = M — m™
D—|M—n

|5 Mo Connect X

Picture 3.12. Place->Wire

C—h—01

23



Step 14: left-click on one terminal of R1

o

[/R1/1 Mumber1 ]

Rz
ik

Picture 3.13. Left-click on a terminal of R1.

Step 15: move cursor to a terminal of R2 until see a Red circle.

e 1k
-:-v-:c—nl—

% [/R2/2 Number:2] |

Picture 3.14. Move cursor to a terminal of R2.

Step 16: left-click on the terminal of R2 to finish the routing between R1 and R2.

Picture 3.15. Complete routing between RI and R2.
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Step 17: follow step 13 to step 16 to complete the wiring of the circuit as in the

picture below.

=
:

e

Picture 3.16. Completed circuit

Step 18: double click on “0Vdc”

V1

Budi——
[ | T

§ R1
1k

§ R2
1k

Picture 3.17. Double click on “0Vdc”

Step 19: change Value to 5Vdc then select OK.

() Walus if W alue Exists

Drefault

Carcel

Display Properties *
: Fant
E0E B ial 7 [defaul]
e |ﬁ-!dc | Change... Uze Default
Dizplay Format
Col
(") Do Mot Display i
(@) Value Orly ¥ |
() Mame and Value o
() Mame Only @0 O 180
() Both if ¥alue Exists ) an O 270

Test Justification

Picture 3.18. Change Value to 5Vdc
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Step 20: go to Place->Ground...

- (SCHEMATICT : PAGET]]

to place GND symbol into design page

Tools 5l Analysis P5p|ce Accessones Options  Window Help

f [ | & Part..
|

PSpice Component...

Database Part
2= | L Wire
Auto Wire
| 1 Bus
| =B Junction
| A BusEntry
! = Met Alias...
3 Power...
|+ Ground...

| [21. Off-Page Connector...

| ., Hierarchical Block...
< Hierarchical Port...

I-K Mo Connect

Title Block...

Rrnlkrark

= ™

Bl ™ & ™M . @

T
HW O OW S Lt
SEEELET L

Vi

Picture 3.19. Place->Ground...

Step 21: Select 0/CAPSYM

Place Ground

Symbal;

o

0TSk
0/Dezign Cache
GMND/CAPSYM
GMHD/Design Cache
GMND_| E.-'l'-.HTH.’E.-'-‘-.F'S"r’M ]

Libraries:

't

gh Cache

/‘”‘\ Cancel

Add Library...

Remowve Libram

Help

Marme:

IJze 0/CAPSYM zumbol to place a do ground
MetGroup Ground
[ ] Show UnMamed MetGroup

Picture 3.20. Select 0/CAPSYM
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Step 22: Wiring GND to circuit

é R1
1k

ol M1
5Vde—

1k

oL

Picture 3.21. Wiring GND to circuit

Step 23: go to PSpice->Create Netlist

Analysism,ﬂ\ccessories Options  Window Help

WD (] Mew Simulation Profile & m i ]
PP I R L 1
Create Netlist
| ViewNetlist
. Advanced Analysis »
Markers L4
Bias Points L4
R1
1k
» | N
5Vde—

Picture 3.22. PSpice->Create Netlist

Step 24: Go to PSpice->View Netlist to view netlist of this circuit

WGET)]

| Analysis Accessories  Options  Window Help

[ New Simulation Profile

W > | B 38 B E ¢
B RO N i I K2 L [ |+ |8
] Create Metlist
View Netlist
Advanced Analysis L4 I
Markers 4
Bias Points 4
R1
v 1k
5Vde——

Picture 3.23: PSpice->View Netlist
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Step 25: Go to PSpice->New Simulation Profile to setup simulation information

1
ysis Accessories  Options  Window  Help
[~ New Simulation Profile |

Aol 0 RS ke
e T

Create Metlist
View MNetlist

1l

Advanced Analysis L

Markers L3
Bias Points LS

My
B

. || N
5Vde——

Picture 3.24. PSpice->New Simulation Profile

Step 26: set name for profile (anything you want without special characters such

as space, &, #,...)

New Simulation >
h ame:
|DE_ana|_l,l2d |
Cancel
Inherit From:
none i
Root Schematic:  SCHEMATICI

Picture 3.25. Set name for profile then click Create

Step 27: Setting as in the picture below

B Simulation Settings - DC_analyze x

General

Analysis

Options
Data Collection

Probe Window

Configuration Files

Analysis Type:
Bias Point

Options:

¥ General Settings
Temperature (Sweep)
Save Bias Point
Load Bias Point

Output File Options

Include detailed bias point information for nonlinear controlled sources and
semiconductors (.OF)

FPerform Sensitivity analysis ((SENS)

7|

Output variableis):
Calculate small-signal DC gain (.TF)
From Input source name:

To Output variable:

Cancel || |

| oK I Apply |

Reset | Help

Picture 3.26. Simulation setting then click OK
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IV.

Step 28: go to PSpice->Run to run simulation

ET)]

1alysis Accessories  Optiens Window  Help

| [ New Simulation Profile | Y gt
> il

— Edit Sirmulation Profile " E

} 4 (@ AU [ 1 R L Dt

) Wiew Simulation Results  F12
View Output File ; . @

Create Netlist

SCHEM jew Netlist

Advanced Analysis 4

Markers L3

Bias Points 4 R1
1k

L|w
SVdc— {

Picture 3.27. Run simulation

Step 29: click V button to show results.

]

sis  PSpice  Accessories  Options  Window Help

AAAOY OV OWILIE S bk I [+

nable Bias Voltage Display k ] ﬂu
HEMATL..™
R1
1k
v
bVde ——
T
Step 30: Fill report
PREPARATION AT HOME

Install OrCAD PCB Designer Lite on your computer.
Equation of Voltage divider?

REPORT

Filling the practice results into template of report in the next page.
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LAB 4

DC SWEEP AND TRANSIENT IN PSPICE

I. GOAL
In this lab, student will have skills:

= Simulate circuits with DC sweep and transient mode in PSPICE

II. SUMMARY OF THEORY
a. DC Sweep
It is a simulation mode in DC. In this mode, DC voltage/current of suppliers will
change in specific ranges with specific steps to analyze DC characteristics of

circuits.

D1

I

LT
Dbreak

*V1
OVde—— R1

-T 100

Picture 4.1 DC Voltage-Ampere characteristic of a diode
In the circuit of picture 4.1, voltage of V1 changes in the range from 0.2V to
1.0V with step is 0.05V, the changes of DC current through D1 is plotted to

show the voltage-ampere relation in D1.

b. Transient (Time domain)
This mode of simulation shows how a circuit operates its function. Time to
analyze is the most important thing. It requires start time that is usually zero and

stop time. The smaller step of simulation time, the higher accuracy of simulation.
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D1
i ouT

11
Dbreak

V1
VOFF =0 R1
VAMPL =1 100
FREQ = 1kHz
AC=
>0

-0

Picture 4.2. Output voltage on wire “OUT” in transient simulation
A transient simulation example is showed in picture 4.2. An AC source with sine
wave is connected to a diode circuit to work as a single phase rectifier. Stop time of

the simulation is 10ms with the step of 10us. Output waveform shows the result of

operation of this circuit.

Transient simulation is one of the most important simulation mode not only to

check and learn but also to prove functions of a circuit.

III. PRACTICE
a. Equipment

= OrCAD PCB Designer Lite

b. DC sweep
Step 1: open Capture CIS Lite and draw a circuit as in the picture 4.3.

e To place name for a wire such as Vin:
o Place->Net Alias...
o Write a name such as Vin then click OK
o Click on a wire on schematic to place the name above for that

wire.

e To place a port such as OUT:

o Place->Hierarchical Port...

o Select a port type such as PORTLEFT-L then click OK
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o Click on schematic page to place that port.

o Wiring a wire to the port.

o Double-click on PORTLEFT-L label to change port name such

as change to OUT.
§ R1
10k
— - Jour
R2 Q1
vin
vy o
L M2 | N Qbreaki
Evdc——  OVdc—— 1k
=0 =1 =% ]

Picture 4.3 NPN transistor testing circuit

Step 2: select PSpice->New Simulation Profile

: PAGET)]
5l Analysis Accessories  Options Window  Help
| New Simulation Profile ' 5 P
PORTLEFT " = s E
I: Edit Simulation Profile " F'il :Hg “{E: @
[ R F11 ¢!
LB A B Y I EE IS W L LS
_ _ Yiew Simulation Results  F12
by o View Output File o @
Create Metlist
E ) View Metlist
—
Advanced Analysis »
Markers L4
Bias Points L4
§ R1
10k
—___Jout
Rz o

Picture 4.4. Setup a simulation
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Step 3: setup name of simulation

Mew Simulation >

Marme:

| DC_sweep | -
| Cancel |

Inkent From:

i ol=

Foot Schematic:. SCHEMATICT

Picture 4.5 Setup name of simulation

Step 4: configure simulation options as in the picture below then click OK

B Simulation Settings - DC_sweep

General Analysis Type: Sweep Variable
DC Sweep h ’

e : | | & Voltage source Mame: Vi
Options: Current source Model type

Configuration Files =
¥ Primary Sweep Global parameter Model name:

Options ] Secondary Sweep ~Model parameter Parameter name:

Data Collection )" Monte CarloAWorst Case L Temperatlis

Probe Window [l Parametric Sweep Sweep Type —
Il Temperature (Sweep) Start Value: 0
[ Save Bias Point ©/Linear End Value: 5
| Load Bias Point Logarithmic Decade Increment: [0

 Value List
0K || cancel || Apply Reset Help

Picture 4.6. Simulation options for DC sweep

Step 5: Create netlist of the circuit

Step 6: Run simulation (PSpice->Run) and wait for PSpice A/D Lite window

shows 100%

=

48 SCHEMATIC1-DC_sweep - PSpice A/D Lite - [DC_sweep.dat (active]] X
= @
cadence” - = x

B File Edit View lation  Tr Plot Tools Window Help B
FRHEEE R ELEIEE T e e )
QA8 S-B Vi X herhds CNODRDERENE=

TR EPEe

pspices Stat= 0 YR End=§

Total job fime [u

INFOIDRPROBE: o — v
< / \\

>

El< > 4 b \Analysis {Waich ]\ Devices S

wi=s \ oo | —

Picture 4.7. PSpice A/D Lite
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Step 7: go to Trace->Add Trace...

E SCHEMATIC1-DC_sweep - PSpice A/D Lite - [DC_sweep.dat (active)]

E File. ‘Edit View Simulation

Plot Tools Window Help %

EPEPEe pE

&l b

= =) - Add Trace... Insert
Delete All Traces  Ciri+Delete
Q, @5 ﬁ % v B Undelete Traces Ctrl+U

#% Fourier

Performance Analysis...

Cursor

Macros...
Measurements...

Evaluate Measurement...

Picture 4.8. Add trace

Step 8: Find and select V(OUT) to plot

Add Traces

Muoize [WEiHz]
Alias Mames

Subcircuit Modes

IV2:+] * [ Analog

[E[Q1]

V[NOOBET) [ Currents
Y(d1:c)

YIR1:2]

W+

W2

ViR 43 variables listed

Simulation Qutput VW ariables
IB[E1]
Crioital

15[31]
YIMOOEE

. Paower
W(O1:e]
YIR21)
W]
Y]
alvall b

i |
IE[G1]
Wil ‘oltages
W[ 1:b)
YIR1:1]
WiR2:2)
W24
ViR
Ful List

2 ( ‘“ [ SCHEMATICI-DC sweep | |

Functionz or Macros
I—ﬂ.nalog Operators and Functiohs w
(l

+

4
=

ABS[)

ARCTAN[]

ATAN[]

AMET]

BVGE

CO5(]

oy

CB(]

ERMM&R ]

ERMMIN, ]

ExF[ ]

Gl

IMG[ ]

LOG[ )

LOGI0(]

M ]

MA ] 27

Trace E=prezsion: |V[EILIT] Win) WOUT]

| Lok ] [cancel | Hep |

Picture 4.9. Select V(OUT) then click OK
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Step 9: do step 8 again to plot V(Vin)

Add Traces

Simulation Output ¥ ariables

| B

IC[01]
IE[QT]
15(01)
W]
WiMOO0BET]
WMODE16]
VIOUT)
W[31:b)
Wd1:c)
Wil:e]
WIR1:1]
WiR1:2)
YIR2:1)
WiRZ:2)
WT:+]
W
W2 +]

VEZ-

Y1[R1]
Y1IRZ)
Y1)
Y12
W2IR1]

Full Ligt

~ Analog

Drigital
[+] ¥oltages
Currents
Fower

Moize [v*/Hz]
[+] Alias Mames

Subcircuit Modes

43 variables listed

Functions or Macros

|.-’-‘malog Operators and Functionz !

ABS[)
ARCTAN[ )

ATAN[]

ANG[)

AMGH] L)

COS(]

Df]

DB

ENvhAX . |

ENWMINI . )

ExP[)

G[]

IMG( )

LOG[)

LOG10()

M[ ]

b ) &

Trace Expression: |VNin]

| [ok ] cancel | Hep |

Picture 4.10. Select V(Vin) to plot then click OK

Step 10: result

Picture 4.11. Waveform result
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¢. Transient

Step 11: change circuit to the circuit below

R
10k
—  Jout
R2 Q1
—n &

L Ve V3 Qbreaki
SVdc——  VOFF =D 1k

- VAMPL = 1v

FREQ = 1kHz
AC =
=0 =0 ]

Picture 4.12. New circuit

Step 12: select PSpice->New Simulation Profile

Step 13: setup name of simulation

Mew Simulation *
Mame:
|Transienli |
Cancel
Inkerit Fram:
none o
Root Schematic:  SCHEMATIC

Picture 4.13 Setup name of simulation

Step 14: configure simulation options as in the picture below then click OK

B Simulation Settings - Transient X
General Analysis Type: Run To Time : 10ms seconds (TSTOF)
Time Domain (Transient)
Analysis : :
Options: Start saving data after : i] seconds
Configuration Files 7 ) Transient options:
) General Settings Maximum Step Size 0.00001 seconds

Dplions Monte Carlo/Warst Case

Data Collection

Probe Window

Parametric Sweep
Temperature (Sweep)
Save Bias Point

Load Bias Point

Save Check Point

Restart Simulation

Skip initial transient bias point calculation (SKIFEF)

Run in resume mode

| Output File Options... |

oK || cancel || Apply |

Reset ||

Help

Picture 4.14. Simulation options for transient

Step 15: Repeat from step 5 to step 10 to get result
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IV.

PREPARATION AT HOME

Simulating the circuit in the picture 4.1 using R = 100 Q, Diode = 1N4001, DC
voltage varies from -10 V to 10 V.

Plot the I curve of the diode.

REPORT

Filling the practice results into template of report in the next page.
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LAB S

AC SIMULATION AND FREQUENCY
RESPONSE IN PSPICE

GOAL
In this lab, student will have skills:

= Simulate frequency response of circuits using AC mode in PSPICE

I1. SUMMARY OF THEORY

a. Frequency response

Frequency response is used to analyze dynamic characteristics of a circuit or system.
It measures the ratio between output and input when changing frequency of input

signal. The result tell us how fast of the circuit or system.

Results of frequency response are usually plotted in Bode-plot as in picture 5.1.

Corner
| Vout Freguency
Gain =20 log T fe
b, ) b,
( PassBand ) ! | StopBand
0dB - ]'
3dB +—-3dB (457
Frequency Slope =
= Response -20dB/Decade
=N
3 s
Bandwidth
- -
Ph fe (P Freguency (Hz)
0° — (Logarithmic Scale)
457
Phase
Shift
-90°

Frequency (Hz)

Picture 5.1 Bode plot
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In the picture above, corner frequency (or cuttof frequency) is the frequency of

input signal that decreases the ratio line amount of -3dB (or the frequency when the

ratio between Vout/Vin decreases amount of 1/ V2 ).

b. AC simulation

AC simulation in PSPICE is a simulation mode that allows changing frequency of

input signals and analyzes characteristics of circuits or system in frequency domain.

______________

AC=1
188Hz 18KHz
O 28% LOG(U{OUT)/U(VUin))
Frequency

Picture 5.2 Bode plot of a simple lowpass filter citcuit

III. PRACTICE
a. Simple Low-pass circuit

Step 1: open Capture CIS Lite and draw a circuit as in the picture 5.3.

R1
Y Apn jout

V1 100
VOFF =0 ; — =
VAMPL =1 @ 10nF
FREQ = 1kHz

AC =1
-0 =0

Picture 5.3 Simple low-pass filter circuit

R1
Vin : ; ;
vi - J | | |
VOFF =0 c1 D S N :
VAMPL = 1 T 1o0F : i :
FREQ = 1kHz i : :
_!'3 L L 1

1.8Hz

=i =0

1.8MHz
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Step 2: select PSpice->New Simulation Profile

MATICT : PAGET)]
Place Sl Analysis [ Accessories  Options Win_dow Help
[ New Simulation Profile 1 T i
o = E
|— Edit Simulation Profile " B;l .
O 4 4 o8 - & £ K2 Lk o [x (£
View Simulation Results  F12
View Output File -] W0 i
j Create Metlist
i | View Netlist
Advanced Analysis L4
Markers 3 R‘I
Bias Points 4
KLYV :
100
Vi
it
VOFF =0 i — e

Picture 5.4. Setup a simulation

Step 5: Setup a name for simulation profile

Mew Simulation >
M ame:
[ad] |
Cancel
Inherit From:
none e
Root Schematicc:. SCHEMATICT

Picture 5.5 Setup a name
Step 6: Configure simulation parameters as in picture 5.6

- Analysis Type: AC Sweep

- AC Sweep Type: Logarithmic

- Start Frequency: 1 (it means 1 Hz)

- End Frequency: 1e6 (it means 1 x 10° Hz or 1 MHz)

- Points/Decade: 100 (more points, more accurate but slow simulation time)
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B Simulation Settings - AC

General Analysis Type:

AC Sweep/MNoise
Analysis
Options:

Configuration Files
¥ General Settings

Options Monte Carlo/Worst Case

Data Collection Parametric Sweep
Prabe Window | Temperature (Sweep)
Save Bias Point

Load Bias Point

AC Sweep Type

Linear
) Logarithmic

Decade

Start Frequency: 1
End Frequency: 1e6
Points/Decade: 100

“Moise Analysis

Enabled

Cutput Voltage:
IV Source:

Interval:

Cutput File Options

Include detailed hias point information for nonlinear controlled sources and

semiconductors (.OP)

Lok ]

Cancel ||  Apply | Reset

| Help

Picture 5.6 Simulation parameters for AC Sweep

Step 7: Create netlist of the circuit

Step 8: Run simulation (PSpice->Run) and wait for PSpice A/D Lite window shows 100%

Step 9: In PSpice A/D Lite, go to Trace->Add Trace...

Step 10: In Add Traces window, type function as in picture 5.7 then click OK

Add Traces

Simulation Output ¥V ariables

®

Functions or Macros

Analog Operators and Functions

Frequency A [ # ~
:EE}I .]1] Analog 9
I[FH.] Digital L
I[R1:1] ;
] Yaoltages ;
W1+ (@
Vi) Cuirents AES()
VIC1:1) ARCTAM[]
sk N~ ATAN( ]
. AVG[
VIR Muaoize Ve Hz) BB ]
WIR1:2] i COS[]
VT +] Alias Mames D
WA e
Viiin] Subcircut Hodes ERYMA] |
W1[C1) EMMIAIMNT . ]
W1[R1] EXF[ )
Calvall Gl
WZ[C1] IMG[ ]
W2[R1] LOGI ]
WEMN] : ; LOGI00 ]
W | 25 variables listed M
WIR1] L b ] W
Full Ligt
Trace Expreszsion: | DEMOUTII | I (] I Cancel Help

Picture 5.7 Add signal to plot in the function of Decibel (DB)
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Step 11: Right click on the plot and select Cursor On to display cursor on plot
Step 12: Using arrow keys to move cursor to -3dB and find out frequency at that position.
b. Simple High-pass circuit

Step 13: Change the schematic to the circuit in picture 5.8.

C1
Vin | louT
Vi 10nF
VOFF =0 R1
VAMPL = 1 @ ; 100
FREQ = 1kHz
AC=1
-0 -0

Picture 5.8 Simple High-pass circuit
Step 14: Repeat step 2 to step 12 to find cutoff frequency of this circuit.
c. Simple BJT Amplifier

Step 15: Create new project for the circuit in picture 5.9.

I
é EB1 B3
10k 10k
louT
e Q1
Vin |, bt
1k e QbreakN
de=" V2
T VOFF =0
VAMPL = 1 9
FREQ = 1kHz B2 = 3 R ==+ G2 == i
AC=1 10k 1pF 15k 10uF 1pF
) 0 0 i | = gt | il

Picture 5.9 Simple BJT Amplifier
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Step 16: Setup Transient simulation profile as in picture 5.10

B Simulation Settings - trans

X
General Analysis Type: Run To Time : 10ms seconds (TSTOP)
_ Time Domain {Transient)
Analysis Dptions: Start saving data after : 0 seconds
Configuration Files " ) Transient options:
, . BanvedSalings Maximum Step Size  |0.00001 seconds
Options Monte CarlofWorst Case
Dats Collechion — Skip initial transient bias point calculation (SKIPEP)
Probe Window Temperature (Sweep) . e
Save Bias Point PRI et we | Output File Options... |
Load Bias Point
Save Check Point
Restart Simulation
| oK || Cancel ||  Apply Reset Help |
Picture 5.10 Transient simulation parameters
Step 17: Run simulation and plot signals V(OUT) and V(Vin).
Step 18: Repeat step 2 to step 12 using parameters as in picture 5.11 to find cutoff
frequency of this circuit.
- Start Frequency: 1 Hz
- End Frequency: 1€9 (it means 1 GHz)
- Points/Decade: 1000
B Simulation Settings - AC1 X

General

Analysis
Configuration Files
Options

Data Collection

Frobe Window

Analysis Type:
AC Sweep/Moise

Cptions:

¥ General Seftings
Monte Carlo/Warst Case
Parametric Sweep
Temperature (Sweep)
Save Bias Point

Load Bias Point

AC Sweep Type

Linear Start Frequency: 1
Logarithmic End Frequency: 1e8
Decade Points/Decade: 1000

Moise Analysis
Enabled Qutput Voltage:
I Source:

Interval:

Qutput File Options
Include detailed bias point information for nonlinear controlled sources and

semiconductors (.OF)

| OK || Cancel ||  Apply Reset Help

Picture 5.11 AC Sweep parameters
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IV.

V.

PREPARATION AT HOME

REPORT

Filling the practice results into template of report in the next page.
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LAB 6

P-N JUNCTION DIODE AND RECTIFIER

CIRCUITS

I. GOAL
In this lab, student will have skills:

= Making three basic types of rectifier circuits.

= (Calculate characteristics of rectifier circuits.

I1. SUMMARY OF THEORY

a. Half-wave Rectifier

I

=
AC Diode AN
v 0 Vo
Input Vs
O O -

+Wiax

v E ! Resultant Output Waveform

AC Input Waveform

Picture 6.1. Half-wave Rectifier

Average DC voltage is calculated from below equations:
Ve ="22=0.318 x V oy = 0.45x Vg

Load current is

(1)

2)
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b. Full-wave Rectifier

i. Two diodes

\J/ Current flows
when O
conducts

AC
Input
Current flows
when Oy
conducts

Resultant Output Waveform

Picture 6.2. Full-wave Rectifier with two diodes

Average DC voltage is calculated from below equations:
Ve =250 = 0.636 X Vpax = 0.9 x Vg

Load current is

ii. Four diodes (bridge)

HE

® <
o

Picture 6.3. Full-wave Rectifier with diode bridge

3)

(4)
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Th

e circuit has two working cycles:

Positive half-cycle: D3 and D4 open because of reverse bias, DI and D2 conduct in
series
Negative half-cycle: D1 and D2 open because of reverse bias, D3 and D4 conduct in

series

Load

a) Positive cycle b) Negative cycle

Picture 6.4. Working cycles of full-wave Rectifier with diode bridge

Equations of this kind of circuit are same with full-wave Rectifier with two diodes.

I11.

PRACTICE

a. Half-wave Rectifier

Step 1: wiring a circuit as in picture 6.1 with AC voltage is 6VAC-50Hz, RL is 1kQ.
Step 2: capture waveform on RL using oscilloscope, find Vpp and frequency.

Step 3: measure Vipc using Digital VOM.

Step 4: calculate I.pc on RL.

b. Full-wave Rectifier with two diodes

Step 1: wiring a circuit as in picture 6.2 with AC voltage is 6VAC-50Hz, RL is 1kQ.
Step 2: capture waveform on RL using oscilloscope, find Vpp and frequency.

Step 3: measure VLDC using Digital VOM.

Step 4: calculate ILDC on RL.

c. Full-wave Rectifier with diode bridge

Step 1: wiring a circuit as in picture 6.3 with AC voltage is 6VAC-50Hz, RL is 1kQ.

Step 2: capture waveform on RL using oscilloscope, find Vpp and frequency.
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IV.

Step 3: measure VLDC using Digital VOM.
Step 4: calculate ILDC on RL.

PREPARATION AT HOME

Simulate circuit in picture 6.3 and generate its netlist.

REPORT

Filling the practice results into template of report in the next page.
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LAB 7
RECTIFIER CIRCUIT WITH

CAPACITOR FILTER

L. GOAL
In this lab, student will have skills:
= Making basic types of rectifier circuits with capacitor filter (smoothing
capacitor).

= (alculate characteristics of rectifier circuits with capacitor filter.

I1. SUMMARY OF THEORY

a. Half-wave Rectifier

Diode Smoothing
H . Capacitor
© 1 . ?
AC a) ’__-
R, | == Output
Input Vs ': CI i
o— I 1] -4

Crutput Waveform
c Charges C Discharges with Capacitor

NANANE M
ov < Qutput Waveform

v L \ = Without Capacitor
- o _ Resultant Output Waveform

AL Input Waveform

Picture 7.1. Half-wave Rectifier with smoothing capacitor

To simplify, the charging time of capacitor goes to 0 because of very large R.C time
constant. The maximum voltage on the capacitor after charging is Vcmax = Vo) =
V max — V p. After that, this voltage is slowly discharged to V cimin = V o(min) through

Ry in a period of discharging At.
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At

A
Ws(pk:
s(pk) IVD
Vo{pk)

Picture 7.2. Waveform

Vdc — VCmax;'VCmin — Vo(pk)‘;Vo(min) (5)
_At At
Vimin = Ve(At) = Voprye R = Vi (1 —m) (6)
Vripple(pk—pk) = Vmax — Vemin (7)
— V ripple(pk—pk) - Vopk
Vip = 2 "~ 2fR.C (8)
At
Vae=Vopn (1 —35.¢) ©)
1
= Vo(pk) (1 —m) (10)
b. Full-wave Rectifier with diode bridge
= Bridge
Rectifier

+

L3
T i

- Smoothing |
Capacitor el
o
C Charges C Discharges _. Waveform
Ripple e N ¥ e with
— T — N Caracitar
fN N N 8N T

£ AP L AP R
oy d \ v \ \ Capacitor

Resultant Output VWaveform

Picture 7.3. Full-wave Rectifier with smoothing capacitor



'-.]

V i Tsz 1 i ps -
Vo ST i Vo
Vs(pm---\lf---\t --------- +=‘---------:-:+ ---------- B LT MRS (SRR
DI N 74 W 0 w7 £ e 0 4 N
omn) NN PN RN
HIEURUCTEL W/ LN
HCO.VD x ‘9: < . P < 9 <
D, Cond ]jzl(j,onfd' D, Cond D@ Cond
Picture 7.4. Waveform
14 +Viemi 14 +V i
VdC — Cmax2 Cmin _ o(pk) > o(min) (11)
_At At
VCmin = VC(At) = Vo(pk)e RC = Vo(pk) (1 - RLC) (12)
Vripple(pk—pk) = Vemax — Vemin (13)
_ Vripplek-pk) _ Yok
Vip = 2 "~ 4fR[C (14
At
=~ Vopn (1 —15=) (16)
o(pk) A4fR;C

c. Ripple factor

Because of large smoothing capacitor, the discharge curve can be considered as

linear. The effective ripple voltage (full-wave) follows equation:

1% Vp

—_Yrp _
Vipern =5 = Farr.o {17
Ripple factor:
14 14
r = _TpEfh _ o(pk) 18
Ve VB@AfRLC)V ¢ (18)

The smaller r, the higher filter quality.



VI.

VIIL.

VIII.

PRACTICE

a. Half-wave Rectifier

Step 1: wiring a circuit as in picture 7.1 with AC voltage is 6VAC-50Hz, RL is 1kQ.
Step 2: use a 100uF capacitor to the circuit.

Step 3: capture waveform on RL using oscilloscope.

Step 4: measure Vipc using Digital VOM.

Step 5: calculate I.pc on RL.

Step 6: calculate Vrp.

b. Full-wave Rectifier with diode bridge

Step 1: wiring a circuit as in picture 7.3 with AC voltage is 6VAC-50Hz, RL is 1kQ.
Step 2: use a 100uF capacitor to the circuit.

Step 3: capture waveform on RL using oscilloscope.

Step 4: measure VLDC using Digital VOM.

Step 5: calculate ILDC on RL.

Step 6: calculate Vrp and ripple factor.

PREPARATION AT HOME

Simulate circuit in picture 7.3 and generate its netlist.

REPORT

Filling the practice results into template of report in the next page.

56
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LAB 7: RECTIFIER CIRCUIT WITH CAPACITOR FILTER
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Output
waveform
Half-wave
Rectifier
Voltage Vibc=.oviiiinnn... Ricad=.eovviiiniin.. Iipc=...ccooils
Cfilter=...............ooeal. Vripple = ...
Output
waveform
Full-wave
Rectifier
Voltage Vibc= coiiiiiiinnnn. Ricad=..iiiiiiiiiiii. Iipc=.ocoeeenn.
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LAB 8

ZENER DIODE AND DC VOLTAGE
REGULATOR

I GOAL

In this lab, student will have skills:

* (Calculating and making basic Zener diode circuit.

» Designing a simple DC voltage regulator using Zener diode.

II. SUMMARY OF THEORY

a. Zener Diode

o—

Cathode
(K)

Symbol

;r Anode
(A)

Reverse Bias

+I:
Forward
Current
Forward
Bias
Region

Ve

'z
| ") p Ve

I — e Forward Bias
Zimin} \
F
0.3-0.7v
“Zener” Breakdown
Region
Ii{'r' ax) — ®# - — 7 I
Y Reverse
Constant Current
Zener Voltage iR

Picture 8.1. Voltage-Ampere characteristic of zener diode

Operation conditions:

- Input DC voltage must be greater than Zener voltage:

Vibc>Vyg

- Current going through the diode must be:

I 7zminy < Iz < Iz@max
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b. DC Voltage Regulator

Zener diode V,

vg(?) = Vs cos i

C ol ‘o
V[V :

—C T Ry Oou(?)

Transformer Rectifier _—

RC filter and
voltage regulator

Picture 8.2. DC Voltage Regulator using zener diode

In the circuit on Picture 8.2, Rs is limited current resistor for zener diode circuit.

The DC input voltage is:
Vipc=V,=V;-14
We have the following equations:
Vibce=Vz

IS=I2+IL

Vibpc
IL == RL

[o = VLDC_VZ
S — RS

Iz=1Is—1p

To ensure the operation of zener circuit and protect it from damage (I z > I z(max))s

value of Rs must be in the range as equation below:

ViDC(max) - VZ < Ro < ViDC(min) - VZ
= IS

I7zmax) + I Limin) I zminy + I L(max

In the case there is no Ry (It=0A), Iz will be equal to Is, therefore:

IZ =IS < IZ(max)
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Power dissipations will be:
Pz =Vzx1Iz<Pzmax
Prs =R, X% I%

c. Transistor Series Voltage Regulator

B Tt a A
.1 oL
¢ T Vinc 11 - IIB VLDT:L§1|L
T by
+

Picture 6.3. Transistor Series Voltage Regulator

Equations:
Vibc=Vz—-Vgg
I,=1;+1Ig
Vioc—Vz

Il= R1

Vipe
Ry,

Ig Iy
"B+1 B+1
Iy
B+1

IL=

I

IZ=I1_IB=II_
Power dissipations:

Pp=VcrgoXIco=Vipc—Vipc) xIco
Bl
B+1

= (Vibc = Vipc) xBlIg=(Vipc — Vipc) X

= (Vibc = Vipec) X I < Ppmax
Pz =Vzx1z7 <Pzmax

PR1=R1XI%

Output impedance:
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I11.

IV.

PRACTICE
a. DC Voltage Regulator
Step 1: calculating Rs value for circuit as in picture 8.2 using Zerner 3.3 V /1
W, C =1000 uF and RL =390 Q.
Step 2: wiring circuit in step 1.
Step 3: measuring VLDC.
Step 4: changing RL to 39 Q and measuring VLDC again.

b. Transistor Series Voltage Regulator
Step 5: wiring circuit in picture 6.3 using Zerner 3.3 V/1 W, C=1000 uF,R1 =1
kQ, RL =390 Q and BJT is 2N2222A
Step 6: measuring VLDC.
Step 7: changing RL to 39 Q and measuring VLDC again.

PREPARATION AT HOME

Simulating circuit in picture 8.3 and generating its netlist.

REPORT

Filling the practice results into template of report in the next page.
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LAB9

BJT TRANSISTOR AND SMALL SIGNAL
AMPLIFIER

L. GOAL
In this lab, student will have skills:
= Examining operation of BJT transistor.

* Investigating AC characteristics of BJT transistor in a small signal amplifier

circuit.

I1. SUMMARY OF THEORY

& Vo
R
Re IcRe
Iz O
1€ o Vout
|
Cy :
|
I
%,
Vin Rz
O
O

Picture 9.1. Small signal amplifier using BJT transistor in common Emitter mode

DC characteristics:
" R{+R,
R, R
Rjp —_ 12
R+ R,
_ Ves—VBE
Rg+ (B+ 1)Rg
Ic=BIp
Vee=Vee— (Rec+ Rp)lc

Vs Vee

Ig
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Temperature stabilized factor:
Rp + Rpg ~1
R+ (1 +B)Rg

Rp

Si=(1+B)X +R_E

Small signal characteristics (with bypass capacitor CE):

- Input impedance from base:

dVvy
Zi = dIbe = hie
- Input impedance from source of signal:
7= dV; _ Rphie
'S7dI;  Rp+h
- Voltage gain:
A _herC _ hfeRC
Y hle B hle
- Current gain:
I
Al == I—Z == hfe
I Rp
Ap===A;x
‘b i 1 RB + hie
- Output impedance:
V, 1
Zo=T) “Toe

Z,=TollRc = R¢

III. PRACTICE

Step 1: wiring circuit as in picture 9.1 using 2N2222A, R1 =R2=10kQ, RC=1.5
kQ, RE =1 kQ, C1 =Cout = 10 uF, CE =47 uF

Step 2: measuring VBB, VBE and VCE.

Step 3: applying a sine wave 100 mV Vpp - 1 kHz to Cl1.

Step 4: measuring output waveform using oscilloscope.

Step 5: calculating voltage gain.

Step 6: changing frequency of input signal until voltage gain decreases 3 dB.

Step 7: adding potentiometer Rx as in picture 9.2 below
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O +Veo

Vin

Picture 9.2. Adding Rx to measure input impedance.
Step 8: applying a sine wave 100 mV Vpp - 1 kHz to Rx.
Step 9: tuning Rx until Vi=Vin /2.
Step 10: removing Rx out of the circuit.
Step 11: measure Rx value.

Step 12: adding potentiometer Ry as in picture 9.3 below

& +Vcoco
Caur
Vout

o
| |
I

R

y
%,
Vin
Ow
—)

Picture 9.3. Adding Ry to measure output impedance.
Step 13: applying a sine wave 100 mV Vpp - 1 kHz to C1.
Step 14: tuning Ry until output voltage decreases a half of output value when there
is no Ry in the circuit.
Step 15: removing Ry out of the circuit.
Step 16: measure Ry value.
Step 17: removing Ry and CE from the circuit.
Step 18: repeat step 4 and 5.

65



IV.

PREPARATION AT HOME

Generating netlist of the circuit in picture 9.2

REPORT

Filling the practice results into template of report in the next page.
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LAB 10

JFET AND SMALL SIGNAL AMPLIFIER

I. GOAL
In this lab, student will have skills:

* Examining operation of JFET transistor.

» Investigating AC characteristics of JFET transistor in a small signal amplifier

circuit.

II. SUMMARY OF THEORY

Voo

RIZ:I II::
C arr

& §R1 KAT'(_(E?M
Vin @ Y - Ve
+ 1 \ECE’ A l
AVEREE G N
C_J b : F f_:}[]‘-.-’

Picture 10.1. Small signal amplifier using JFET transistor in common Source mode

DC characteristics:

Ves=—Vs=—Rglp

Ip=1Ipss(1 —%)2

Vps=Vpp—(Rp+ Rg)Ip

Small signal characteristics (with bypass capacitor Cs):

- Transconductance:
g = dlp =|2—’D55|(1_ Vs )= 1 Gs
M dVgs  Vgsosyl Vsors mo Vgsorr

- Voltage gain:
Ay =—3gmZr=—9dgmRp
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I11.

IV.

Input impedance:

7. - R, = TR
7 76T R+ R,
Output impedance:
Zo=Tgqg

Z,=r4llRp = Rp

PRACTICE

Step 1: wiring circuit as in picture 10.1 using 2SK30, RD =2.2 kQ, RS = 1.5 kQ,
R1=R2=1MQ, RE =1kQ, Cl =Cout=10uF, CS =47 uF

Step 2: measuring VG, VGS and VDS.

Step 3: applying a sine wave 100 mV Vpp - 1 kHz to Cl1.

Step 4: measuring output waveform using oscilloscope.

Step 5: calculating voltage gain.

Step 6: removing CS from the circuit.

Step 7: repeat step 3 to step 5.

PREPARATION AT HOME

Generating netlist of the circuit in picture 10.1.

REPORT

Filling the practice results into template of report in the next page.
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Output waveform

Step 5
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Step 7

Output waveform
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